リリースノート 1.5.2.3

はじめに

ここでは、grandMA3 を使い始めるにあたり、いくつかの必要な手順について述べます。マニュアルでは機能について詳しく説明されています。また MA University の MA e-Learning では各種トレーニングを提供しています。すべての情報は、MA Lighting のWebサイト www.malighting.com からアクセスできます。

右上隅にある I agree をタップして Release Notes から抜けると、grandMA3 ソフトウェアのメイン画面が表示されます。右側には、あらかじめ定義されたビューバーが表示され、ビューボタンをタップすると、そのビューに切り替わります。

grandMA3 ソフトウェアを使い始めるには、まずいくつかのフィクスチャにパッチする必要があります。あるいは、ソフトウェアに付属しているデモショーを読み込むこともできます。どちらの場合も、Menu キーを押してください。grandMA3 onPC ソフトウェアを使用している場合は、左上にある gear シンボルをクリックすると、卓で Menu を押すのと同じ動作になります。

Backup をタップし、ポップアップ・メニューで Load をタップしてください。これで、ショーを読み込む準備ができました。すぐに始めたいので、タイトルバーにある Shows ボタンを繰り返しタップして Demo Shows に変更します。 デモショーが一覧表示されますので、いずれかを選んでダブルクリックするか、それを選択して Load Show をタップしてください。すでに読み込まれているショーがある場合は、新しいものを読み込む前に、現在のショーを保存するかどうかを尋ねられますので、必要に応じて選んでください。

このようにして簡単に、grandMA3 ソフトウェアで作業する準備ができました。右側には画面内容を変更するためのビューボタンが、下部にはエンコーダバーとコマンドラインがあります。形式的には、これだけで始められます。詳しくは、ビューバーの Help というビューボタンで開く grandMA3 の Help ウィンドウか、MA Lighting のWebサイト にあるオンラインヘルプを参照してください。grandMA3 ソフトウェアを段階的に学びたい場合は、MA e-Learning に参加してください。MA Lighting のWebサイト から無料で利用できます。

grandMA3 ソフトウェアを楽しんで利用してください。
以下では、このソフトウェア・バージョンにおけるすべての改善および変更点について述べられています。

ヒント
grandMA3 ソフトウェアは、前回閉じたときにアクティブだったショーファイル(または状態)で起動します。

バグフィックス Version 1.5.2.3

その他の機能強化

grandMA3 command wing XT および grandMA3 onPC rack-unit の Windows IoT イメージが更新されました。Windows IoT のバージョンは 20H2 になり、さらにドライバーも更新されました。


変更点


修正されたバグ

コマンドラインとマクロ

説明
Do not save をタップした場合も、ショーファイルの変更内容が保存されていたのを修正。
IfOutput にディマー値を指定して実行すると(例: IfOutput At 0)、ソフトウェアがクラッシュする場合があったのを修正。
MIDI via onPC command wing が無効の場合でも、MIDIメッセージが onPC command wing で処理されていたのを修正。
grandMA3 onPC Windows の起動時に、SHOW 引数を用いてショーファイルを読み込めなくなっていたのを修正。
複数のショーファイルが立て続けに読み込まれて Layout ウィンドウが表示されると、ソフトウェアがクラッシュする場合があったのを修正。
エンコーダを回しているとき、それを押しながら回すように変えると、アトリビュートが予期しない値に飛んでしまうのを修正。
macOS 上で grandMA3 onPC を起動中にウィンドウのサイズを変更しようとすると、クラッシュする場合があったのを修正。
Cue Only を有効にしてキューを保存すると、ソフトウェアがクラッシュする場合があったのを修正。
Screen Encoder が無効の場合、有効な5番目のアトリビュート・エンコーダに、チャンネル機能の代わりにエンコーダの分解能が常に表示されていたのを修正。分解能は、MA を押しているときに表示されます。

プレイバック

説明
シーケンスに対してDMXリモートが設定されている場合、トリガーイベントが発生していなくても、時々トリガーされることがあったのを修正。
HTP優先度のシーケンスを再生すると、期待通りに動作しなかったのを修正。
すでに実行中のシーケンスに大量のアトリビュートを追加すると、誤った出力が生じる場合があったのを修正。

ウィンドウ

説明
Layout ウィンドウと複数のエンコーダバー・ウィンドウが同時に表示されていると、ソフトウェアがクラッシュする場合があったのを修正。
Layout ウィンドウで、フィクスチャを表すレイアウト要素がちらつく場合があったのを修正。
UI Color - MiniEncoder.IndicatorBack が定義されていないカラーテーマをインポートすると、ソフトウェアがクラッシュする場合があったのを修正。
使用されているフォントにない文字をレンダリングしようとすると、ソフトウェアがクラッシュする場合があったのを修正。このような文字はレンダリングされません。
他のエディタ(例: Macro Editor)が開いているときに、エクゼキュータバーでエクゼキュータをタップして Assign メニューを開くと、ソフトウェアがクラッシュする場合があったのを修正。

grandMA3 Version 1.5.2.1

概要

grandMA3 version 1.5.2.1 の最新リリースでは、照明エクスペリエンスを豊かにするいくつかの機能強化が行われています。以下の簡単な説明を読み、詳しくは関連リンクを参照してください。


Playback Engine

Absolute と Relative レイヤ

このリリースでの改善点

プレイバック・エンジンでは、Absolute と Relative レイヤが互いに分離されました。これによって、さまざまなプリセットからの Absolute と Relative データを簡単に組み合わせることができます。

既知の制限
MIBは、Absolute 値でのみ機能します。

プリセットの値を呼び出した後、そのプリセットを次にタップすると、プリセットに含まれていないレイヤのプログラマ値は破棄されます。

 

Release 値

このリリースでの改善点

プログラマで任意のアトリビュートに Release 値を設定すると、実際の Release 値が保存されるようになりました。

 

Stomp と Capture

このリリースでの改善点

Stomp の動作がさらに改善されました。マルチステップの相対フェイザーを Stomp すると、ステップ2以降は削除され、Relative 値が0になります。
ステップ1の設定値は、Absolute レイヤでは Default 値に、Relative レイヤでは 0 に設定されます。

プリセットを呼び出す際に、Stomp を直接実行できるようになりました。
例:
相対サークル・フェイザーがドラマーの周りで動作しているとします。
フィクスチャを選択し、Stomp を押してから、別の絶対 Position プリセット(例: シンガー)をタップすると、ライトは円を描かずにシンガーに向きます。この Position プリセットを Stomp なしで呼び出した場合、ライトはシンガーの周りを回ります。

プリセットごとに、Stomp を自動的に呼び出すかどうかを指定できるようになりました。プリセット編集の Settings にある Stomp で有効にできます。

 

このリリースでの新機能

新しいキーワード Capture (Stomp Stomp) は、選択されているフィクスチャの非デフォルト値をプログラマにノックインします。マルチステップ・フェイザー実行中にノックインされるのは、ステップ値ではありません。Capture を実行した時点での出力値(2ステップ間のいずれかの値)がノックインされます。

Capture を用いると、新しいキューにフェードインするとき、あるいはクロスフェードを行うときに、現在の出力値をノックインすることもできます。


キューパートとプログラマ・パート

このリリースでの改善点

Track Sheet および Fixture Sheet でのパートの表示が改善されました。

Sequence Sheet:
キューが複数のパートを持ち、一つのパートに一つのアトリビュート値しかない場合、パート0以外のパートにある値を確認するために Track Sheet モードでキュー全体を展開する必要はありません。Track Sheet では、キューが折りたたまれていると、すべてのキューパートの値がキュー行にマージされます。他パートからの値セルの右下には、それが由来するパートが表示されます。

Fixture Sheet:
プログラマに異なるパートからの値がある場合、現在選択されているプログラマ・パートに含まれていないアトリビュートのセルは、すべて暗色で表示されます。

このリリースでの改善点

Absolute および Relative 値の変更にともない、プリセットの種々のパート・プロパティは Cue Part だけに削減されました。Cue Part は、プリセットがどのパートに呼び出されるかを指定します。デフォルトでは、すべてのプリセットに対して値が 0 に設定されています。この設定を変更するには、コマンドラインに EditSetting を入力し、目的のプリセットをタップします。EditSetting ポップアップで、Cue Part をタップし、新しい値を入力して Please で適用します。ここで指定されたパートは、エンコーダを用いてプログラマで値をアクティブにするときにも使用されます。

重要
grandMA3 v1.4 以前で保存されたショーファイルを読み込むと、古いパート・プロパティは破棄されます。

特殊値と Pan/Tilt Offset

このリリースでの新機能

特殊値は、フィクスチャタイプによって定義された値の代わりに、フィクスチャごとのアトリビュートの Default 値、Highlight 値、および Lowlight 値を変更するために用いられます。
例えば、プログラマのクリア後に一つのフィクスチャの Pan/Tilt が 50%/50% に戻らないようにしたい場合、あるいは、Highlight 機能がアクティブになったときに一つのフィクスチャを白の代わりに緑にしたい場合などに利用できます。どちらの場合も、これらのフィクスチャ自体に対応する値を変更することで対応できます。

プリセットがアトリビュートの Default 値として使われている場合、Fixture Sheet にはプリセット情報による新しい表示が用いられます(例: 0 の代わりに 1.1 Closed)。プリセット情報の表示方法は、Fixture Sheet の Preset 設定にもしたがいます。

ヒント
プリセット値を更新するときにプリセットを特殊値として用いる場合、特殊値はプリセットの更新値も使用します。

特殊値は、異なる方法で設定できます。

フィクスチャ編集による方法

  1. "Edit Fixture 1" のようなコマンドを実行するか、Fixture Sheet でフィクスチャ名を右クリックしてください。
  2. Fixture Editor が開き、このフィクスチャの全アトリビュートの一覧が下部に表示されます。Default、Highlight、および Lowlight に対応するセルは、長押しするか右クリックすることで編集できます。
  3. 電卓が開き、任意の値を直接入力できます。フィクスチャが呼び出せるプリセットを選択するには、右側の Preset で目的のプリセットをタップするか、SpecialsReset to Original をタップして対応するフィクスチャタイプに保存されている標準の値に戻ります。 また Special で Extract を選ぶと、プリセットの値が取得され、プリセットへのリンクなしでそれが適用されます。プリセットの値はアトリビュートによって保持されますが、後からそのプリセットが更新されても変更されません。
    あるいは、対応するプリセットのセル(Default Preset、Highlight Preset、または Lowlight Preset)を編集してプリセットを選ぶこともできます。その場合、まずショーファイルで利用可能なフィーチャグループをドロップダウンで選び、次に選択されたフィクスチャで目的のアトリビュートに利用できるプリセットを選択します。
    この場合のドロップダウンには、Reset to OriginalExtract の項目もあります。

Parameter List で RTChannels (Realtime Channels) を変更する方法

  1. Parameter List(Menu - Patch / Live Patch - Parameter List)に移り、目的のフィクスチャのアトリビュートにスクロールして、上の「フィクスチャ編集による方法」で述べた電卓による手順にしたってください。

コマンドラインによる方法

必要条件:
目的の値は、プリセットを呼び出したり、アトリビュート・エンコーダを回したりして、プログラマでアクティブにする必要があります。

User name[Fixture]> Store Default
User name[Fixture]> Store Highlight
User name[Fixture]> Store Lowlight

特殊値をリセットするには、プログラマで対応するアトリビュートを Remove 値に設定し、そのタイプの特殊値に保存します。あるいは、対応するアトリビュートに任意の値を設定し、Store Remove を行います。現在アクティブな値の Default 値について Store Remove を行うには、以下のように入力します。

User name[Fixture]> Store Default /Remove

Highlight や Lowlight 値のリセットも同様に行えます。上例の Default を、Highlight や Lowlight に置き換えてください。
また、特殊値への Release 値の保存は、Remove と同様の効果があります。

ヒント
コマンドラインを利用する場合、どのフィクスチャの特殊値が変更されるかについては、Store Options の Use Selection と If not empty 設定が重要になります。
Use Selection および If not empty 設定については、Store Settings とプリファレンスの保存 を参照してください。
制限
・特殊値の保存は、Absolute 値によってのみ可能です。Relative 値は無視されます。
・複数ステップを持つプリセット(フェイザー)は、特殊値として利用する場合、ステップ1だけが用いられます。

 

このリリースでの新機能

フィクスチャごとに、Pan Offset と Tilt Offset を指定できるようになりました。これは、ショーの事前プログラミングやツアーショーで、フィクスチャが予定通りに吊られていなかった場合にとても役立ちます。Offset 値は、Fixture Sheet には表示されませんが、DMX Sheet には表示されます。この機能は、実際のフィクスチャの状態がプログラミング終了時まで分からない場合に有用です。
Pan Offset と Tilt Offset 列を表示するには、Menu - Patch/Live Patch に移り、Columns を Full に設定します。値を変更するには、目的のセルを選んで長押ししてください。電卓が開きますので、必要な値を入力して適用します。

今のところオフセットは、ユーザプロファイルで選択されている DMX Readout にしたがって表示されます。

Patch に移らずにオフセットを指定するとこも可能です。オフセットを適用したいフィクスチャに対して、プログラマにプリセットを呼び出すか、キューを再生します。3D と実際のステージ上で Position を確認できるようにしておいてください。これらのフィクスチャの Pan/Tilt をプログラマで調整し、実際のステージ上で、オフセットが不要な場合とまったく同じ位置に当たるようにしてます。
そして、以下を実行してください。

User name[Fixture]> Store Offset

これによって、Offset 値が計算され、選択されているフィクスチャに入力されます。

Store がすでにコマンドラインに入力されている場合、ショートカットの MA + Update によって Offset キーワードが得られます。

ヒント
・Store Offset では、結果のオフセットができるだけ小さいほど正確になります。
・Offset キーワードでは、プログラマで相対値を用いることもできます。
制限
今のところ、Patch メニューで Offset には正の値しか入力できません。

アジェンダ

このリリースでの新機能

アジェンダは、カレンダーにしたがって、スケジュールされたコマンドを卓で実行するために用いられます。また、毎年のクリスマスイブなどのイベントを繰り返しスケジュールすることもできます。

Agenda ウィンドウを開くには、Add Window ダイアログの More タブで Agenda をタップします。

Agenda ウィンドウには、データ表示のためにいくつかのモードがあります。これらのモードを切り替えるには、タイトルバーにある ViewMode をタップしてください。モードは以下の通りです。

Month、Week、および Day 表示モードでは、無効なアジェンダ・イベントは赤文字で表示されます。また、繰り返されるイベントの右側には アイコンが表示されます。Month、Week、および Day 表示モードの各日には、その日に予定されているイベント数も表示されます。この場合、その日に何度も繰り返されるイベントは、一つのイベントとしてカウントされます。

アジェンダの有効/無効は Running で切り替えられます。

Sheet 以外のカレンダー表示モードでタイトルバーの Today をタップすると、現在の月、週、日に移動できます。

Today の隣にある左/右矢印ボタンをタップすると、表示モードに応じて前後の年、月、週、日に移れます。

新しいアジェンダ・エントリーを作成するには、Sheet モードに切り替えて New AgendaEvent を右クリックするか、他の表示モードでタイトルバーの Setup によってツールバーを開き、+ に続けて目的の日付をタップします。

アジェンダ・エントリーには、ユーザが指定できる以下のプロパティがあります。

Sheet および Year 以外の表示モードでアジェンダ・イベントを編集すると、Edit Agenda ポップアップが開き、Sheet 表示モードと同じプロパティを変更できます。

Sheet モードでは、選択したアジェンダ・エントリーをテストするためのボタンが追加表示されます。タイトルバーの Test selected をタップすると、選択されているアジェンダ・イベントが直ちに実行されます。これによって、設定されているオブジェクトやコマンドが正しく実行されるかを確認できます。

Delete Old は、先行するすべてのイベント(有効な期間も含む)を削除します。

Agenda ウィンドウの左端にツールバーを表示することができます。ツールバーを有効にするには、タイトルバーにある Setup をタップしてください。
以下のツールを利用できます。


レイアウト

このリリースでの改善点

レイアウトについて、いくつかの改善点があります。

Layout Editor に、ViewPosActive というオプションが追加されました。これをオンにすると、レイアウトを再度読み込んだ際に、以前に保存されたビュー位置とズーム値が呼び出されます。オフの場合、保存されているビュー位置とズーム値は、ビュー全体を再度呼び出したときにのみ呼び出せます。このボタンは、デフォルトでオフになっています。

レイアウトにセレクションを割り当てる際に、選択されているフィクスチャのグリッド位置が利用されます。

Setup モードの Layout では、現在のセレクションを、3D ウィンドウのカメラビューと同様の位置に変換できます。この機能を適用するには、レイアウト・エンコーダバーの Function を Arrangement に切り替えて、Layout TypeCamera になるまでタップします。 新しい位置が適用される前に、エンコーダで以下のようなパラメータを指定できます。

エンコーダをタップすると、値を直接入力するための電卓が開きます。Camera に対する電卓では、既存のカメラをリストから選んだり、カメラのIDを直接入力したりできます。

新しい Resize Fixed Ratio ()ツールを用いると、実際のアスペクト比を保ったままレイアウト要素のサイズを変更できます。
アスペクト比も変えてレイアウト要素のサイズを変更するには、通常の Resize () ツールを選んでください。

Layout ウィンドウの Grid プロパティが、SnapGridVisibleGrid に分けられました。SnapGrid は、レイアウト要素を移動する際に用いられるグリッドのサイズを指定します。

VisibleGrid は、表示グリッドのサイズを指定します。

Layout View では、キーボードの DelIns キー、およびショートカットの Ctrl + A を使用できます。

レイアウト要素に、内容や境界線を指定可能なテキストを設定できるようになりました。そのために以下のプロパティが追加されています。

レイアウト要素の描画に階層が導入されました。階層によって、どのレイアウト要素が他の要素によって覆われるかが決まります。
階層は以下のように適用されます(最高レベル → 最低レベル)。

  1. 選択されたオブジェクトは、常に他のすべての要素の上に表示されます。
  2. オブジェクトが割り当てられているレイアウト要素。
  3. Environment フィクスチャが割り当てられているレイアウト要素。
  4. 空のレイアウト要素(テキストや境界線だけが指定されたレイアウト要素も含む)は、常に最下位に表示されます。

Element Visible を無効にすると、レイアウト要素を非表示にできます。

レイアウト要素の大きさが、キャンバス全体を覆う最大 14,000 × 14,000 ピクセルまで許容されるようになりました。

Fixture ID や Custom ID をレイアウト要素上に表示するには、ID (= Fixture ID)や CID (= Custom ID) を有効にしてください。Custom ID が表示されている場合、レイアウト要素のサイズが十分に大きいと、対応するIDタイプも表示されます。その場合、IDタイプはIDの前に表示されます。Fixture ID と Custom ID が異なる場合は、FID:CID という形式で別々に表示されます。

例えば Channel 1:1001 の場合、レイアウト要素に割り当てられたフィクスチャは、Fixture ID が #1、Channel ID が #1001 です。

プリセットをレイアウトに割り当てられるようになりました。それらをタップすると、プリセットプールのプリセットのように動作します。

制限
既存のショーファイルは、プリセットの Layout Element Defaults を取得できません。新しいショーにだけが、プリセットの Layout Element Defaults を持ちます。

3D ウィンドウ

このリリースでの新機能

3D ウィンドウで、Iris の IrisRandomPulseClose と IrisRandomPulseOpen アトリビュートが視覚化されるようになりました。

ピクセルが同一平面上にある場合、マルチピクセル・フィクスチャの各ビームは1本のビームにまとめられます。これによって、この種のフィクスチャタイプのパフォーマンスが向上します。ピクセル配列が円や正方形に近い場合、このビームのレンダリング方法が用いられます。
各ピクセルが互いにどの程度ボケかは、ビームのジオメトリごとに "Multi-Beam Blur" というプロパティで指定できます。このプロパティの値範囲は0.1〜1で、値が大きいほどビームのボケが大きくなります。

Beam Quality に "Gobo Animated" が追加されました。この Gobo Animated 以上の Beam Quality では、ゴボホイールのスロット間遷移がアニメーション化され、スナップ遷移やフェード遷移が視覚化されます。また、Gobo#SelectShake、Gobo#WheelSpin、および Gobo#PosShake アトリビュートも視覚化されるようになりました。
フィクスチャタイプのホイールに "Allow Shortcut" というプロパティが追加されました。これは、ホイールが2スロット間の最短距離を取るのか、DMX値の昇降にしたがうを指定します。デフォルトでは "No" に設定されています。

ヒント
Gobo#WheelSpin アトリビュートも、Beam Quality "Gobo" で視覚化されますが、ホイールスロット間のアニメーションはありません。

Import/Export メニュー

このリリースでの新機能

インポートやエクスポートのための新しいメニューは、メインメニューから開けます(Menu - Import / Export)。メニュー左側にあるタブバーの Import または Export をタップすることで、データをインポートするかエクスポートするかを選べます。

どちらのタブも構造は似ていますが、メイン領域(後述を参照)が入れ替わります。
メイン領域は、ハードドライブやUSBドライブ上のファイルを表す Drive セクションと、ショーファイル内のデータを表す Local セクションに分かれています。
Import タブでは、Drive セクションが左側、Local セクションが右側にあります。Export タブでは、これが入れ替わって、Local セクションが左側、Drive セクションが右側になります。これら二つのセクションに加えて、メニューのタイトルバーにある ObjectType をタップすると、さまざまなオブジェクト・タイプを切り替えられます。またこれをスワイプすると、利用可能なすべてのオブジェクト・タイプが3列に分割されてドロップダウン表示されます。最初の列にはデータプールにまとめられていないオブジェクト・タイプ(例: Appearances、Scribbles、User Profiles など)が、2列目には種々のメディア(Images、Videos、Sounds など)があります。そして最後の列には、データプールにまとめられているすべてのオブジェクトとデータプール自体が一覧表示されています。他のすべてのオブジェクト・タイプはデータプールの子になるので、それらの名前の前には マークが表示されます。例えば PresetPools を選択すると、メイン領域の上部にタブバーが追加表示され、種々のプリセットプールを切り替えられます。

Drive セクションのタイトルバーにある Internal をタップすることで、選択したドライブを変更することもできます。
Local セクションでは、DataPool によって、ショーファイルで利用可能なデータプールを切り替えられます。
Sheet Style を有効にすると、選択した ObjectType のプールが、デフォルトのプール形式ではなくシート形式で表示されます。
Drive セクションでは、Name の後の入力欄を用いてファイルを検索することもできます。

Export タブの Local 領域には、追加の機能ボタンがあります。Select All をタップすると、現在のオブジェクト・タイプの要素がすべて選択されます。このときボタンは Deselect All に変わり、これをタップすると、すべてのオブジェクトの選択が解除されます。

各エリアでは、一度に複数のエントリーを選択できます。Sheet Style では、投げ縄選択や、Ctrl を押しながら個々にタップすることで、複数のオブジェクトを選択できます。Local 領域が Sheet Style でない場合、プール・オブジェクトをタップしていくと、それらが現在のセレクションに追加されます。選択したプール・オブジェクトをもう一度タップすると、その選択を解除できます。

オブジェクトをエクスポートするには、Export タブの Local 領域で対象を選択し、Drive 領域でファイル名を入力するか既存のファイルを選んで、Export をタップします。

ファイルからオブジェクトをインポートするには、Import タブの Drive 領域でファイルを選択し、Local 領域でデスティネーションを選択して、Import をタップします。

画像をインポートする際に、メニューの下部にある Create Appearance を有効にしておくと、取り込んだ画像を用いてアピアランスを直ちに作成できます。


Readout とエンコーダの分解能

このリリースでの新機能

新しい Readout の "Natural" を用いると、アトリビュートごとに望ましい表記方法のタイプを指定できます。 例えば、ディマー値ではパーセント表示が適していますが、Pan/Tilt 値では度で表す物理表記の方が分かりやすいでしょう。
Fixture Sheet、Sequence Sheet、またはユーザプロファイルの Readout を設定する場合、Percent や Physical などの代わりに Natural を選択できます。

Natural Readout は、Menu - Patch / Live Patch - Attribute Definitions で Natural Readout 列のセルを編集することによって、アトリビュートごとに指定できます。新しいショーでは、Natural Readout の定義済みセットが作られます。新しいアトリビュートの Natural Readout には Percent が設定されます。

また Natural Readout は、各ユーザプロファイル内でアトリビュートごとに指定することもできます。Menu - Settings - User Configuration - Profiles でユーザプロファイルを選び、Edit Encoder Bar をタップしてください。
ショーに新しいユーザプロファイルを作成する場合、すべてのアトリビュートの Natural Readout は、Default 値を用いて Attribute Definitions のものにリンクされます。

新しいショーを開始したり、新しいユーザプロファイルを作成したりすると、Readout はデフォルトで Natural に設定されます。
grandMA3 v1.4 以前で保存されたショーファイルを読み込むと、Attribute Definitions 内の Natural Readout と同じものが適用されます。また、v1.4 以前から v1.5 以降にショーファイルを一旦移行すると、すべてのユーザプロファイルが Natural 値の Readout に設定されます。

このリリースでの新機能

アトリビュートごとにエンコーダの分解能を指定できるようになりました。エンコーダの分解能は、エンコーダを1クリック回したとき、アトリビュート値がどれくらい変化するかを決めるものです。これは、Attribute Definitions (Menu - Patch / Live Patch - Attribute Definitions)内の Encoder Resolution 列で、アトリビュートごとに変更できます。値の変化量は、アトリビュートごとの現在の Readout にも依存します。

Natural Readout と平行して、User Profile メニューの Edit Encoder Bar で、ユーザプロファイルごとにエンコーダ分解能を指定することもできます。新しいユーザプロファイルを作成すると、現在の Encoder Resolution 設定も Attribute Definitions からコピーされます。

エンコーダの分解能を、エンコーダ上で直接変更することもできます。MA を押している間、各エンコーダのチャンネル機能エリアが、可能な分解能の表示に切り替わります。このときエンコーダの分解能エリアをタップすると、選択されている分解能が次の分解能に変わります。これによって、ユーザプロファイルにあるアトリビュートの Encoder Resolution が変更されます。目的の分解能が選択されたら、MA を離してください。

ヒント
・エンコーダの1回転あたりのクリック数は24です。
・分解能が Coarse の場合、アトリビュートを最小値から最大値まで全範囲に渡って変化させるには、エンコーダを5回転させる必要があります。

可能な分解能は以下の通りです。

ヒント
Native モードが選択されていて、例えば Dimmer チャンネルが 8/16/24 ビットベースの場合、エンコーダを1回転させるとDMX出力が常に1桁変化します。

エンコーダバーにあるエンコーダ表示の中央には、現在の分解能を表すシンボルが表示されます。Coarse は4個のドット、Fine は8個のドット、Increment は4個のドットと4個の楕円が、また Native は歯車状のシンボルで表されます。

さらに、エンコーダの内側リングを回したときや、他のすべてのエンコーダ操作(内側リングを押し回す、外側リングを回す、外側リングを押し回す)における値変化のファクタは、Edit Encoder Bar メニューで指定できます。利用可能なファクタは以下の通りです。

各ファクタに設定可能な値は以下の通りです。

新しいユーザプロファイルを作成した場合、Encoder Press Factor は Mul5、Dual Encoder Factor は Div5、Dual Encoder Press Factor は Div25 に設定されます。

TimeLayerResolutionPhaserLayerResolution ボタンで、選択されているレイヤに応じて異なる分解能を設定できます。TimeLayerResolution はデフォルトで Fine に、PhaserLayerResolution はデフォルトで Coarse に設定されています。

Link Resolution は、エンコーダの分解能を切り替える際に、同じフィーチャグループの他のすべてのアトリビュートの分解能も切り替えるのか(FeatureGroup)、現在の分解能を変更している一つのアトリビュートの分解能だけを切り替えるのか(Single)を指定します。この設定は、エンコーダの分解能を変更するために、エンコーダバーで MA を長押しすることによってもアクセスできます。


Patch と Live Patch メニュー

このリリースでの改善点

Patch メニュー内で、より構造化されたワークフローを実現するために、いくつかの改善が加えられました。

Patch メニューのナビゲーションを、左側のタブバーで行うように変更されました。これにより、Patch のどの部分を見ているのかを常に把握できます。特に Attribute Definitions のようにサブセクションがある場合、セクション領域の上部にタブバーが表示され、サブセクションを移動できます。

実際のパッチを確認するために、2種類のスタイルを利用できるようになりました。タイトルバーで、Split View を切り替えられます。Split View を無効にすると、従来バージョンの grandMA3 のように、フィクスチャ・パッチの完全なツリー構造の概要を確認できます。有効にすると、新しい Split View が表示されます。上部のタブバーによって、パッチを LayersClassesID TypesFixtureTypesDMX UniversesFilters、または Hierarchy ごとに分割して表示できます。Split View の左側エリアには、該当するオブジェクトが表示されます。これらのオブジェクトの一つをタップして選択すると、それに対応するフィクスチャが右側に一覧表示されます。

Split View で新しいフィクスチャを追加する場合、Fixture ウィザードの設定は現在の分割にしたがいます。例えば、Layers タブでレイヤを選択すると、そのレイヤが Fixture ウィザードに表示されます。また、Fixture Type タブでフィクスチャタイプを選択すると、そのフィクスチャタイプのフィクスチャが作成されます。

カテゴリー間で要素のカット&ペーストを行うと、貼り付け先でカテゴリーが自動的に調整されます。

Patch メニューは、前回の選択していたタブを記憶していて、再度メニューを開いたときにそのタブに戻ります。

変更を行わずに Patch メニューを抜けた場合、確認ポップアップは表示されず、Oops スタックもクリアされません。

 

このリリースでの改善点

フィクスチャタイプの CanHaveChilderen フラグが "No" に設定されている場合、このフィクスチャタイプのフィクスチャは、どのフィクスチャの親にもなれません。CanHaveChildren フラグのデフォルトは、ほとんどのフィクスチャタイプで "No" に設定されていますが、必要に応じて手動で "Yes" に設定することもできます。

 

このリリースでの改善点

Edit Patch メニューに、以下のボタンが追加されました。

新しいフィクスチャを挿入するとき、"Select DMX Mode to use" の "In current show" タブに "No" (Number)という新しい列が表示されます。これは、Fixture Types の一覧に表示されているインデックス番号です。

Patch メニュー、Live Patch メニュー、Fixture Type セクション、および Insert New Fixture ダイアログのタイトルバーに、Hide Environmental という新しいボタンが追加されました。これを有効にすると、一つのDMXチャンネルに少なくとも一つのDMXアドレスが割り当てられていないすべてのフィクスチャタイプが非表示になります。これらのフィクスチャタイプは、主にステージやトラスなどの環境的な項目です。階層的なパッチ項目は再帰的に検索されるため、DMXアドレスを持つDMXチャネルがある子オブジェクトが見つかるとその親が表示されます。

 

このリリースでの新機能

フィクスチャ・ライブラリは、GDTF-Share.com から直接 GDTF フィクスチャタイプをダウンロードできるようになりました。これを行うには、ワールドサーバ に接続するためのアクティブなインターネット接続が必要です。これは、コマンドラインの右側にある緑のワールドサーバ・アイコンで示されます。

Patch (Menu - Patch) に移り、Insert new Fixture をタップすると、Insert New Fixtures ダイアログが開きます。既存のフィクスチャ・ライブラリではなく、GDTF Share をタップしてください。フィクスチャタイプのリストがダウンロードされます。

ヒント
インターネット接続の速度によっては、フィクスチャタイプのリストや個々のフィクスチャタイプのダウンロードに時間がかかる場合があります。

フィクスチャタイプを選択したら、Select をタップしてください。GDTF ファイルのローカルコピーが、選択されているドライブの gma3_library/fixturetypes/gdtfs フォルダにダウンロードされ、ショーファイルに追加されます。フォルダ構造については、このトピックの その他の機能強化 を参照してください。

GDTF Share フィクスチャ・ライブラリに、二つのプロパティが追加されました。"Uploader" は、ファイルがユーザまたは登録メーカによって GDTF Share にアップロードされたかどうかを示しています。"Rating" は、フィクスチャタイプに対するユーザの平均評価を1〜5(5が最良)で表示します。

ヒント
GDTF Share フィクスチャ・ライブラリには、GDTF-Share.com でリリース・ステータスが "Release" に設定されているフィクスチャタイプだけが表示されます。
さらに、評価やコメントなどを行うには、通常のWebブラウザで GDTF-share.com にアクセスする必要があります。これは、grandMA3 ソフトウェア内ではできません。GDTF Share にはユーザアカウントが必要です。

特殊エクゼキュータ

このリリースでの改善点

特殊エクゼキュータは、その概要を把握しやすいように再構成されました。これらは以下のように配置されています。

特殊エクゼキュータのハードウェア要素の統合にともない、エクゼキュータバーの特殊エクゼキュータ領域も整理されました。これによって、full-size (CRV) および extension の左側エクゼキュータバーの特殊エクゼキュータ領域にスクロールバーが不要になり、すべての特殊エクゼキュータがエクゼキュータバーに自然に収まるようになりました。
さらに、マスター・セクション の特殊エクゼキュータ領域には、上部に特殊エクゼキュータ1〜4が2×2の配列で表示され、下部には選択されているシーケンスが常に表示されます。

すべての特殊エクゼキュータの概要を含む Special Executor Configuration メニューはなくなりました。これは、特殊エクゼキュータに対して Assign メニューを開こうとしたときに表示されていたものです。

 

このリリースでの新機能

ユーザプロファイルごとの新しいオプション Mirror SpecialExecutor によって、grandMA3 extension の特殊エクゼキュータ領域が、すべて同じ特殊エクゼキュータのセットを使用するか(Yes に設定)、あるいは個々の extension が独自の特殊エクゼキュータのセットを使用するか(Noに設定)を指定できます。Mirror SpecialExecutor を Yes に設定した場合、grandMA3 full-size (CRV) の左側エクゼキュータ領域と同じ特殊エクゼキュータが使用されます。
特殊エクゼキュータのセットは、grandMA3 extension の WingID によって管理されます。接続されている2台の extension が同じ WingID に設定されていて、Mirror SpecialExecutor が No の場合、これらの両方の extension は、同じ特殊エクゼキュータを表示・使用します。詳しくは、grandMA3 extensiongrandMA3 extension の接続、および エクゼキュータとは を参照してください。

 

このリリースでの改善点

特殊エクゼキュータに対する Assign メニューが開いていると、選択した特殊エクゼキュータのエクゼキュータ・ラベルが赤と通常の色で交互に表示されます。

特殊エクゼキュータ5(物理グランドマスター・ノブ)に、グランドマスター以外のオブジェクトが割り当てられている場合、エンコーダバーのグランドマスター・フェーダ領域が小さくなります。エンコーダバー下部の空き領域には、特殊エクゼキュータ5に割り当てられたオブジェクトが特殊エクゼキュータ・ラベルに表示されます。

コントロールバー で Custom/Master Section ウィンドウの一時的なオーバーレイを開けるようになりました。 をタップします。

 

このリリースでの改善点

特殊エクゼキュータの再編にともない、Custom/Master Section ウィンドウも改善されました。
Custom/Master Section の設定は、以前のバージョンに比べてプロパティが少なくなりました。現在のプロパティは以下の通りです。

Custom/Master Section ウィンドウで、割り当てられているフェーダ機能が各フェーダの上に表示されるようになりました。

重要
v1.4 以前で保存されたショーファイル内にある Custom/Master Section ウィンドウの全設定は、v1.5 でこれらのショーを読み込む際に、デフォルトにリセットされます。

DMX Curves

このリリースでの新機能

DMXカーブによって、通常の直線的なDMXチャンネル出力を変更できます。例えばディマーを制限したい場合に、フィクスチャの Dimmer アトリビュートを100%にしても90%のDMX値しか出力しないように定義できます。また、スイッチ・チャンネルとして扱われるDMXチャンネルにも利用できます。

DMXカーブは、Patch メニューの DMX Curves セクションで管理できます(Menu - Patch - DMX Curves)。一つのショーファイルには、9,999個のDMXカーブを含めることができます。
CurveModes には、以下の3種類のタイプを指定できます。

新しいDMXカーブを作成するには、DMX Curves メニューで New DmxCurve をタップしてから Insert new DmxCurve をタップします。
CurveMode は目的のモードに変更してください。
右側のグラフ領域でポイントを移動するには、選択ツール()で選択します。
そして、移動ツール()に切り替え、選択したポイントをドラッグし、目的の位置に来たら指を離してください。

Custom カーブでは、さらにいくつかツールを利用できます。

グラフ表示領域には、両方向(In と Out)にルーラがあり、DMXReadout に応じてその目盛りが変わります。横方向(In)はアトリビュートの入力値を、縦方向(Out)は結果のDMX出力を表しています。
カーブ上のポイントには、識別しやすいように名前やIDが表示されます。

Custom カーブでは、ハンドルを用いて、カーブを許容範囲外に動かすことができます。この動作は、例えばオーバーシュートの場合に必要とされるかもしれません。この場合、結果のDMX値は、対応する制限(0 または 255)によってカットされます。このようなカーブでは、Show Warnings という新しいボタンが表示されます。これをタップすると、どのカーブがそのように設定されているかを示す警告ポップアップが表示されます。

左側の一覧で各ポイントの In と Out 値を入力すると、カーブを微調整できます。カーブ名の前にある三角マークをタップすると、そのカーブにあるポイントが展開されます。
MinMax および Switch カーブでは、Min と Max という二つのポイントに制限されていて、追加できません。
Custom カーブでは、対応するセルを編集することで Accel と Decel も調整できます。

ヒント
インポートできる三つの定義済みDMXカーブがあります。これらは、Sinus、Square、および Power Correction 形状のために用意された Custom カーブです。

DMXカーブは、フィクスチャタイプ内のアトリビュートやリアルタイム・パラメータに適用できます。
フィクスチャタイプのアトリビュートの場合、そのフィクスチャタイプを編集し(Menu - Patch - Fixture Types - フィクスチャタイプを選択 - Edit)、DMXModes で目的のDMXモード、DMXチャンネルを展開します。そして、目的のDMXチャンネルの DMX Curve セルを編集してください。
ポップアップが開きますので、DMX Curve タブで、このショーファイルにあるDMXカーブの一つを選択します。また Empty をタップすると、割り当てられているDMXカーブが削除されます

リアルタイム・パラメータ(Menu - Patch / Live Patch - Parameter List)についても同様にDMXカーブを割り当てられます。 Parameter List で目的のパラメータ(IDType、CID および ChannelName で特定)までスクロールし、その DMX Curve セルを編集してください。ドロップダウンが開き、ショーファイルのすべてのDMXカーブが表示されます。このドロップダウンでは、Ignore FT を選択することで、フィクスチャタイプから割り当てられている可能性のあるDMXカーブを無視することもできます。
パラメータにすでに割り当てられているDMXカーブを削除したい場合、フィクスチャタイプで定義されているアトリビュートのDMXカーブを使用することもできます。そのためには、Follow FT を選んでください。

ヒント
リアルタイム・パラメータにDMXカーブが割り当てられているフィクスチャを別のDMXアドレスにパッチした場合、リアルタイム・パラメータのDMXカーブも新しいDMXアドレスに移動します。

Assign メニューと Settings Editor

このリリースでの改善点

オブジェクトの設定を割り当てたり編集したりする際の操作性を統一するために、エクゼキュータの Assign メニューが作り直されました。

左側に表示されるタブは、ObjectHandleEdit Setting、および Edit (オブジェクトで利用可能な場合)になりました。

NameScribble、および Appearance ボタンは、割り当てられているオブジェクトの Edit Setting エリアに移動しました。

シーケンスやマクロを編集すると、Assign メニュー内に関連するエディタが開き、左側のタブで他の設定に戻ることができます。
割り当てられているオブジェクトの設定(例: グループやワールド)は、Edit Setting をタップすることで直接編集できます。

また Settings Editor は、編集可能なオブジェクト全体で同様のレイアウトになっています。Name、Scribble、および Appearance は、常に Settings の左側に表示されます。

Assign メニューがどのように呼び出されたかによって、以下のようなタブで開くようになりました。

これは、新しい /Tab オプションを用いてコマンドラインから以下のように行うこともできます。

ページ1のエクゼキュータ201に Assign コマンド用いて Edit タブを開きます。

User name[Fixture]> Assign Page 1.201 /Tab "Edit"

また、その逆も可能です。Assign メニューを開き、Edit コマンドで Handle タブを表示させるには、以下のように入力します。

User name[Fixture]> Edit Page 1.201 /Tab "Handle"

/Tab オプションに使用できる値は、Object、Handle、EditSetting、および Edit です。

また、これらの追加オプションなしでエクゼキュータバーのエクゼキュータをタップすると、前回 Assign メニューを開いたときに選ばれていたタブが復元されるようになりました。Assign メニューが開くと、選択したエクゼキュータのエクゼキュータ・ラベルが赤と通常の色で交互に表示されます。


onPC の改善点

USB MIDI のサポート

このリリースでの新機能

grandMA3 onPC (macOS/Windows)が、USB MIDI インターフェースに対応しました。

USB MIDI インターフェースの設定を行うには、Menu - Settings - onPC Settings を開きます。 MIDI 列にある MIDI via onPC command wing で、command wing のMIDIポートを入出力用に使用するかをどうかを決められます。 これを有効にすると、MIDIの入出力は connect grandMA3 onPC command wing を介して行われます。 無効にすると、MIDI In DeviceMIDI Out Device で設定されたデバイスが用いられます。それぞれをタップすると、ポップアップでデバイスを選べます。

MIDI Offset では、選択したMIDI入力デバイスに入力されるMIDIノートとコントロールチェンジ(CC)を、指定したオフセット分だけシフトさせることができます。
MIDI TimecodeSlot では、選択したMIDI入力デバイスに対するタイムコード・スロットを指定します。

 

オーディオ入力の選択

このリリースでの新機能

Windows の grandMA3 onPC で、サウンド入力を利用する際に用いるオーディオ・インターフェースを選択できるようになりました。

オーディオ入力を選ぶには、Menu - Settings - onPC Settings を開きます。Sound 列にある Audio In Device をタップすると、可能なオーディオソースを表示するポップアップが開きますので、目的のインターフェースを選択してください。None を選ぶと、grandMA3 onPC ソフトウェアへのオーディオ入力が無効になります。None やその他の利用可能なソースのほかに、Default <オーディオ入力デバイス名> という項目をタップすると、オペレーティングシステムによるデフォルトのオーディオ入力デバイスを選択できます。
また、Sound ウィンドウで、タイトルバーの Audio In Device をタップして、オーディオ入力デバイスを選択できるようになりました。このボタンは、onPC ステーションでのみ表示されます。


MVR Merge

MVRファイルのインポートで、MVRファイルの内容をショーファイルにマージできるようになりました。ユーザは、MVRファイルからの変更を適用するかどうかをフィクスチャごとに決められます。

Patch (Menu - Patch) に入り、Import MVR をタップします。ファイル・ブラウザでMVRファイルを選び、Import をタップすると、MVR Merge メニューが開きます。ここで、ショーファイルの現在の内容と、フィクスチャIDにマッチするMVRファイルの内容を比較します。

左側(My)にはショーファイルのパッチ内容が、右側(Other)にはインポートされたMVRファイルからの内容が表示されます。

ヒント
ショーファイルにフィクスチャがない場合、左側が空になります。

ユーザは、ショーファイルの既存データを保持するか、MVRファイルからのデータで上書きするかを、フィクスチャごとに決められます。青い背景は、適用されるフィクスチャ(My または Other)のデータセットを示してます。

各行で、My または Other のいずれかをアクティブにできます。行の保持したい側をタップしてください。青い背景が選択した側に変わります。選択内容をショーファイルにインポートするには、Import MVR をタップします。

Patch と同様に MVR Merge メニューでも、タイトルバーにある Columns をタップすることで列の表示モードを変更できます。
Columns が Condensed モードに設定されている場合、FixtureID、Name、Fixture Type、および Patch アドレスという最も重要な情報だけが表示されます。
Full モードでは、Position、Rotation、または Class などの追加情報が表示されます。


その他の機能強化

macOS の grandMA3 onPC が、新しい Apple Silicon システム・アーキテクチャに対応しました。

複数のタイムコード・イベントを選択し、Timecode Editor エンコーダバーにある Time エンコーダを回すと、選択したイベントが相対的に移動します。

例えば、Assign メニューでキーの機能を編集するときや、グループの設定で Appearance をタップしたときに開くドロップダウン・リストが、スクロール可能なものとしてではなく、すべての値がグリッドとして表示されるようになりました。

アピアランス:

アピアランスが、より多くの場所で表示されるようになりました。

アピアランスで、割り当てる画像を回転できるようになりました。アピアランスを編集し、目的の向きになるまで ImageRotation をタップしてください。90°ずつ回転します。
また、新しいプロパティ ImageMirror によって、画像をミラー反転できるようになりました。設定できる方向は、Horizontal、Vertical、または Both です。

マクロ:

Phaser Editor の右側ツールバーにある - でステップを削除できます。コマンドラインからは、Delete の他に Insert も利用できます。

ステップ3を削除します。

User name[Fixture]> Delete Step 3

ステップ2を挿入します。

User name[Fixture]> Insert Step 2

ステーションおよびDMXプロトコル(Art-Net または sACN)ごとに、ステーションが IdleMaster である間にこれらのDMXプロトコルを送信するかどうかを指定できるようになりました。これは、複数の卓を用いる大規模なセットアップに役立ちます。このオプションが有効になっていると、1台の卓が元のセッションから外されても、これらのプロトコルが送信されます。これによって、受信デバイスがこれらのソース間で常にジャンプすることがあります。
この設定の有効/無効を切り替えるには、Menu - DMX Protocols - Art-Net または sACN で、SendArtnetIfIdleMaster または SendSacnIfIdleMaster をタップします。 あるいは、Menu - Output Configuration で、現在のセッションに加わっている卓ごとに、SendArtnetIfIdleMaster または SendSacnIfIdleMaster の値を設定できます。
この設定は、すべての卓と onPC ステーションにおいて、デフォルトで有効になっています。 また、v1.4 以前の卓を v1.5 移行に更新すると、SendArtnetIfIdleMasterSendSacnIfIdleMaster が有効になります。

既存の MAtricks プール・オブジェクトに保存するとき、ソフトウェアは、既存オブジェクトを上書きするか、マージするか、あるいはキャンセルするかを尋ねます。

grandMA3 extensions は、ホストに接続しなくてもデバイスのIPアドレスを変更できるようになりました。これを行うには、grandMA3 extension のディスプレイの左下隅をタップしてください。grandMA3 ソフトウェアでのIP設定と同様のポップアップが開きます。詳しくは インターフェースとIP を参照してください。
また、Factory reset をタップすることで、grandMA3 extension の現在の設定を工場出荷時の状態にリセットできます。

重要
これは、grandMA3 full-size および grandMA3 light 卓の内部ウィングでも可能ですが、このメニューはテクニカルサポートの指示がある場合にのみ使用することをお勧めします。

Video プールで、動画をインポートできるようになりました。これらの動画は、アピアランスで画像の代わりに利用できます。

重要
動画ファイルは、ショーファイル内の Media プール全体に対するサイズ制限の200MBにカウントされます。

ハードドライブやUSBドライブのフォルダ構造が変更されました。
すべてのユーザ・データは、gma3_library フォルダに保存されるようになりました。このフォルダは、バードドライブの gma3_vx.y.z フォルダと同じレベルにあります。これにより、バージョンに依存しないユーザ・ファイルの管理が可能になります。USBドライブでは、フォルダは grandMA3 フォルダ内に、そして grandMA3 フォルダはUSBドライブのルートに置かれます。
grandMA3 ソフトウェアからデータをエクスポートすると、gma3_library フォルダ内にファイルが作成されます。gma3_vx.y.z フォルダ内のフォルダは、ソフトウェア自体がインストールするデフォルトのコンテンツにのみ使用されるようになりました。
USBドライブの場合、grandMA3 が動作しているステーションにUSBドライブを接続し、Backup メニューでUSBドライブを開くと、gma3_library フォルダが自動的に作成されます。

gma3_library フォルダ内で、データはサブフォルダに構造化されています。これらのサブフォルダは gma3_library フォルダと一緒に作成され、主に内部データ構造を表しています。以下のフォルダが作成されます。

ヒント
ショーファイルの場所は、エクスポートされたファイルよりもバージョンに依存するため、変更されていません。フォルダの場所は以下の通りです。
・onPC Windows®: C:\ProgramData\MALightingTechnology\gma3_x.y.z\shared\shows
onPC Apple macOS®: HD\users\[username]\MALightingTechnology\gma3_x.y.z\shared\shows
・USB ドライブ: \grandMA3\shared\shows

マスターやRDMデータなど、上述のリストに含まれていないオブジェクト・タイプは、"gma3_library" フォルダに直接エクスポートされます。
また、オブジェクトの親レベルをエクスポートする場合、サブ拡張子を持つ単一ファイルが、対応するフォルダに保存されます。
例えば、DMXプロトコルを Art-Net と sACN に分けずに DMXProtocols (Export Root "DeviceConfigurations"."DMXProtocols" "MyPerfectDMXProtocolsSetup") でまとめてエクスポートすると、"MyPerfectDMXProtocolsSetup.dmxprotocols.xml" という名前のファイルが、"inout" フォルダに作成されます。
これは、すべてのリモートやカメラなど、より多くのオブジェクト・タイプに適用されます。
また、キュー(シーケンスの子)などの子オブジェクトをエクスポートすると、親オブジェクト(シーケンス)の "sequences" フォルダに、"cuename.cue.xml" というようなサブ拡張子付きの名前でファイルが作成されます。

このフォルダ構造の変更後も、grandMA3 デバイスにインストールされている旧ソフトウェアのファイルをインポートできます。
USBドライブ上の既存ファイルを利用できるように、ファイルのコピー機能も実装されています。grandMA3 ソフトウェアは、USBドライブが認識されると、既存の古いフォルダ構造を検出します。そして、旧データを新しいフォルダ構造に移行するかどうかを尋ねるポップアップが表示されます。ここには以下の選択肢があります。

ファイル操作(Import/Export、SaveShow/LoadShow、List)を行う際の新しいコマンドライン・オプションが追加されました。
/Path オプションを用いるとファイルのパスを指定できます。例えば、ファイルがサブフォルダ内にある場合などに便利です。

例:

"gma3_library/data/macros/myfavorites" にある "bestmacro.xml" というマクロ・ライブラリをインポートします。

User name[Fixture]> Import Macro Library "bestmacro.xml" At Macro 5 /Path "myfavorites"

同じフォルダの同名ファイルが、最初に接続されたUSBドライブにある場合は、以下のように入力します。

User name[Fixture]> Import Macro Library "bestmacro.xml" At Macro 5 If Drive 2 /Path "myfavorites"

/Path オプションを用いると、grandMA3 のフォルダ構造内にないライブラリ・ファイルをインポートすることもできます。同じファイルを、USBドライブのルート直下にある "My_grandMA3_files" フォルダからインポートするには、以下のように入力します。

User name[Fixture]> Import Macro Library "bestmacro.xml" At Macro 5 If Drive 2 /Path "/My_grandMA3_files"

/Path オプションの値が / (スラッシュ)で始まる場合、システムはドライブのルートからパスを辿ります。また値が直接名前で始まる場合は、対応するライブラリ・フォルダ(例: gma3_library 内の macro フォルダや resources)から辿ります。


新しい gma3_library (上述を参照)では、ライブラリ・ファイルを利用できる場所が二つになりました。/Type オプションによって、ユーザのライブラリ・ファイル(/Type "User")とシステムのライブラリ・ファイル(/Type "System")を区別できます。

ユーザ MAtricks のライブラリ・ファイルだけを一覧表示するには、以下のように入力します。

User name[Fixture]> List MAtricks Library /Type "User"

定義済み MAtricks のライブラリ・ファイルをすべて一覧表示するには、以下のように入力します。

User name[Fixture]> List MAtricks Library /Type "System"

/Type オプションは、ユーザライブラリとシステムライブラリに同名のライブラリ・ファイルがある場合にも使用できます。save_show というマクロを、ユーザライブラリではなくシステムライブラリからインポートするには、以下のように入力します。

User name[Fixture]> Import Macro Library "save_show.xml" At Macro 21 /Type "System"

/Type オプションは LoadShow でも利用できますが、値が異なります。通常のショーは /Type "Shows"、デモショーは /Type "Demo"、そしてバックアップ・ファイルでは /Type "Backup" で指定できます。

demoshows フォルダからデモショーを読み込むには、以下のように入力します。

User name[Fixture]> LoadShow "Demoshow_grandMA3.show" /Type "Demo"
制限
/Type オプションは、LoadShow、Import、または List に対してのみ使用できます。
重要
タイプが指定されていない場合、"User" が優先されます。

三つ目の新しいオプション /NoRefresh が追加されました。特定のタイプやパスのライブラリ・ファイルを指定する際、コマンドラインで /Type や /Path オプションを入力するのに手間がかかる場合があります。前のコマンドで指定した後にファイルをインポートする場合、通常は Import 構文で /Type や /Path を再入力する必要があります。
/NoRefresh を用いると、後続のコマンドで /Type や /Path を再入力しなくて済みます。

例:

特定パス内のすべてのマクロ・ライブラリを一覧表示します。

User name[Fixture]> List Library If Drive 2 /Path "/My_grandMA3_files/macro/archive"

そして、2番目のライブラリをマクロ1にインポートします。

User name[Fixture]> Import Library 2 At Macro 1 /NoRefresh

/NoRefresh オプションがないと、以下のコマンドを実行する必要があります。

User name[Fixture]> Import Library 2 At Macro 1 If Drive 2 /Path "/My_grandMA3_files/macro/archive"

 

また、/Gaps というオプションも追加されました。このオプションは、インポート時にプール・オブジェクト間のギャップ数を保持するかどうかを指定できます。エクスポート時には、常にギャップが保存されます。 以下の例では、Macro プールにマクロ1、2、4、および8があり、これらすべてのマクロを一つのXMLファイルにエクスポートするものとします。

この例のマクロをエクスポートするには、以下のように入力します。

User name[Fixture]> Export Macro 1 Thru 8 "mymacros.xml"

続けて、エクスポートしたマクロを、マクロ11以降にギャップなしでインポートし直してみます。

User name[Fixture]> Import Macro Library "mymacros.xml" At Macro 11 /Gaps "No"

そうではなく、以前のギャップを保持したい場合は、以下のように入力します。

User name[Fixture]> Import Macro Library "mymacros.xml" At Macro 11 /Gaps "Yes"

この場合、XMLファイルにはすでにギャップが含まれているため、/Gaps オプションを指定しなくてもかまいません。

User name[Fixture]> Import Macro Library "mymacros.xml" At Macro 11

 

DMX Personality セルで電卓を開くと、右側の Specials 領域に各 DMX Personality のボタンが表示されます。これらのボタンは、上述と同じ命名スキームを用いています。
異なるRDMフィクスチャタイプのフィクスチャを複数選択した場合、電卓には最初に選択したRDMフィクスチャの DMX Personality だけが表示されます。この例で DMX Personality の一つを選択すると、それに対応するRDMフィクスチャだけが変更されます。

存在しないRDMフィクスチャが別のRDMポートに接続された場合、そのRDMフィクスチャは以前のRDMポートから削除されます。

以下の場所において、無効なプロパティやオブジェクトなどが赤文字で表示されるようになりました。

Command Controls オーバーレイで、ディマーホイール・エリアを用いてディマー値を変更できるようになりました。選択したフィクスチャのディマー値を変更するには、Full の上にあるディマーホイールをタップしたまま上下にドラッグし、目的の値になったら指を離します。

macOS の grandMA3 onPC は、すでにインストールされている grandMA3 onPC が実行されていない場合にのみインストールできるようになりました。実行中の grandMA3 onPC がある場合、ポップアップが表示されます。

Date & Time メニュー

重要
すべての時刻は、タイムゾーンを考慮したローカルタイムです。正しい現在位置が指定されていないと、予測が適切に行われません。時刻は、海面位の平坦な地形を想定して計算されます。すべての時刻についての最大精度は±1分です。
ヒント
grandMA3 onPC のクリーンスタートを実行すると、オペレーティング・システムから現在時刻とタイムゾーンが取得され、grandMA3onPC ソフトウェアの時刻とタイムゾーンとして設定されます。

Clock ウィンドウ

OSC、PSN、DMX Protocols メニューでは、ステーションに対して出力コンフィグレーションが生成されていない場合、Interface エリアに "No Output Station" というメッセージが表示され、変更を防ぎます。

Copy Cue ポップアップが作り直されました。ドロップダウンの代わりにラジオボタンで選択肢が表示され、概要の把握や操作をより素早く行えるようになりました。また、ラベルも変更されています。

コマンドラインのオプションにも若干の変更が必要です。

Copy Cue ポップアップが設定を記憶するワークフローも変更されました。ポップアップのタイトルバーにある Save をタップすると、次のコピー操作のために設定が保存されます。設定を変更した後で、保存されている設定に戻したい場合は、Load をタップしてください。

OffCue のトリガー・タイプを設定できるようになりました。これを行うには、Sequence Settings で Wrap Around を無効にする必要があります。以下の値を適用できます。

キューのトリガーについては、キューとシーケンスの確認 を参照してください。

OSCメッセージの送信に失敗した場合、System Monitor に適切なフィードバックが表示されるようになりました。ここには、OSC メニューのOSC設定行に対応する番号と名前も表示されます。

エクゼキュータバー

エクゼキュータバーのデザインが更新されました。

Sequence settings

シーケンスには、エクゼキュータやレイアウト上での外観に関して、さらに二つのオプションがあります。

Sequence プールで空のシーケンスを選択するか、空のエクゼキュータを選択することで、新しいシーケンスを直接作成できるようになりました。空のエクゼキュータを選択して作成した空のシーケンスを使用しなかった場合、別のエクゼキュータを選択すると、最初に作成されたシーケンスは削除され、新たに選択したエクゼキュータに新しいシーケンスが作成されます。

Backup メニュー

Backup メニューの新しい設定によって、ショーを保存するときに、メディア・ファイルをハードドライブやUSBドライブに追加エクスポートするかを指定できます。Export Media on Show Save オプションは、Menu - Backup - Settings にあります。これを有効にすると、ショーファイルに含まれる画像、プラグイン、メッシュなどが、ショーを保存したドライブにエクスポートされます。無効にすると、これらのオブジェクトはエクスポートされません。

これにともない、Backup メニューの Settings タブが若干変更されています。Interval ボタンは AutoSave Interval に改称され、左側のラベルはなくなりました。

プリセットには、保存されている値に応じて、Absolute や Relative 値のマーカが表示されるようになりました。マーカは、赤または紫(レイヤ・ツールバーと同じ色)の四角です。

Goto および Load 用のポップアップが実装されました。これを開くには、コマンドラインに Goto または Load を入力します。キーボードでキーワードを入力するか、Goto なら Goto を、Load なら Goto Goto と押してください。その後、シーケンスまたはエクゼキュータを押すと、ポップアップが開きます。
Goto や Load を実行した場合は、選択されているシーケンスに対応するポップアップが直接開きます。

ポップアップ内で、目的のキューまでスクロールしてタップします。上部にある Filter 欄に名前を入力してキューを検索することもできます。

どちらのポップアップでも、キューのアピアランスを表示できます。タイトルバーの Cue Appearance をタップして表示/非表示を切り替えます。この設定は、両方のポップアップによって共有されています。

既知の制限
このため、エクゼキュータのダイレクト・ボタン機能として Goto や Load を使用することはまだできません。

エクゼキュータのボタン機能として Swop を割り当てられます。エクゼキュータ・ボタンを押すと、Swop 機能でシーケンスが再生されます。ボタン機能としての Swop は、Flash や Temp と同様に一時的な機能です。

Swop からシーケンスを保護することもできます。そのためには、目的のシーケンスの Settings で Swop Protect を有効にしてください。これによって、他のシーケンスで Swop が実行されても、このシーケンスはゼロになりません。

Swop は、Playback マスターの影響も受けます。Playback マスターが割り当てられているシーケンスを Swop すると、同じ Playback マスターが割り当てられているシーケンスだけがゼロになります。この Playback マスター以外のシーケンスは影響を受けません。Playback マスター内の Swop Protect も考慮されます。
Swop されたシーケンスで Playback マスターが割り当てられていないものは、同様に Playback マスターが割り当てられていないシーケンスだけがゼロになります。

Installed option

画像、動画、およびプラグインは、新しい設定 Installed を利用できます。これを有効にすると、ステーションは、リソースをショーファイルに取り込む代わりに、インポート元のドライブにあるリソースを使用します。これによって、ショーファイルのサイズを減らすことができます。 新しいステーションをセッションに加える場合は、インストール済みとしてマークされたファイルがそのステーションでも利用できるようにしておく必要があります。
Installed 設定を無効にすると、リソースはショーファイルにインポートされ、それが使用されます。セッションのアップロード時には、これらのリソースが参加しているデバイスにも送信されます。
デフォルトでは、Installed は無効になっています。

新コマンド HelpLua。実行すると、"grandMA3_lua_functions.txt" というファイルが、内部ドライブの gma3_library フォルダにエクスポートされます。このファイルには、grandMA3 固有のすべての Lua 関数が含まれています。
また、このマニュアルには、grandMA3 固有の Lua 関数に関する詳細なトピックがあります。それらについては Lua 関数 を参照してください。 マニュアルは拡張中のため、まだすべての gandMA3 固有の Lua 関数が記載されているわけではありません。最新の内容についてはオンラインマニュアルを参照してください。

Software Update メニューが少し変更されました。

カラー・エンジンが改善されました。減色法によるカラー混合システムを持つカラー測定されたフィクスチャタイプを利用しています。

フィクスチャタイプがエミッタやフィルタの測定データを持っている場合、これによってDMXカーブが作成され、対応する論理チャンネルに対して自動的に適用されます。加色混合によるフィクスチャの場合、エミッタごとにフル出力で少なくとも1回のカラー測定が必要です。DMXカーブは、複数の測定値がある場合にのみ作成されます。減色混合のフィクスチャの場合、スペクトル・データによるカラー測定が少なくとも2回必要です。これらのうち1回は最大挿入時、もう1回は最小挿入時でなければなりません。

ヒント
特に非線形輝度カーブを持つエミッタや非線形飽和カーブを持つフィルタの場合、異なるエミッタ出力レベルやフィルタ挿入での測定値を追加すると、精度を大幅に向上させることができます。

カラーテーマに、プールボタンの選択色のための新しいカラー定義が追加されました。これは Selected と呼ばれ、PoolButton グループ内にあります。これにより、選択されたプール要素(例: Sequence)に対して、フィクスチャの選択色とは異なる色を指定できます。


変更点

User name[Fixture]> Set Selection MAtricks "XBlock" 3
制限
MAtricks 構文を含む既存のマクロは、システムによって変換されません。
制限
このような特定キーワードを用いている既存マクロは、新しい構文に変換でません。
重要
MAgic プリセットは、Selective として保存する必要があります。
重要
v1.4 以前でエクスポートされたシーケンスをインポートする場合、これらのファイル内の Off when Overwritten 設定はインポートできません。この場合、Off when Overridden はデフォルト状態に設定されます。

修正されたバグ

3D

説明
Selection Only が有効になっていると、サブフィクスチャのスポット上にラベルが表示されなかったのを修正。
3D ウィンドウで、矩形ビームを持つフィクスチャに対して視覚的アーティファクトが生じていたのを修正。また、どのような視点でも、矩形ビームが消失することはありません。

コマンドラインとマクロ

説明
別のショーを読み込んで Save をタップしたとき、前のショーファイルが保存されない場合があったのを修正。
Lua 関数の cmd() によって Command Line ポップアップがトリガーされると、卓がクラッシュする場合があったのを修正。System Monitor にエラーメッセージが出力されます。
MA + MA + Pause | Fix と押して卓をロックすると、これらのボタンがロック中に強調表示されたままになっていたのを修正。
List を押したままオブジェクトのハードキー(例: Group など)を押すと、List キーワードもコマンドラインに追加されてしまうのを修正。List キーワードは、List を離したときにのみコマンドラインに追加され、他の操作は実行されません。
フィクスチャの子を選択して、メインフィクスチャ名(例: Fixture "Spot*")を指定すると失敗するのを修正。メインフィクスチャ名を指定した場合にも、再帰的選択が機能するようになりました。
選択範囲の指定に少なくとも一つの名前が用いられているコマンド(例: Fixture 1 Thru "Spot 8")が機能しなかったのを修正。
一つのコマンド内で、再帰的選択に新しい選択を追加できなかったのを修正(例: Fixture 1. + Fixture 2)。
無効なフィクスチャIDで再帰的選択を行うと、すべてのメインフィクスチャが選択されてしまうのを修正(例: Demoshow で Fixture 30. Thru)。このような場合、Command Line History にエラーが表示されます。
Command Section オーバーレイで MA + Update とタップしたとき、コマンドラインに Cook が入力されず、代わりに Update メニューが開いていたのを修正。
フィクスチャを一つだけ含むグループの名前を変更すると、そのフィクスチャ自体の名前も変更されていたのを修正。
単一フィクスチャのグループでは、常にフィクスチャのアピアランスが表示されていたのを修正。3番目のアピアランスを割り当てると、それが Group プール・オブジェクトに表示されます。フィクスチャ自体のアピアランスは変更されません。
"Fixture 301. Thru .1" のような再帰的選択コマンドの入力をキーで行えなかったのを修正。選択コマンドとともに . を用いても、すべての場合で適切に動作するはずです。
ユーザプロファイルで Undo General を無効にしても、MAtricks ウィンドウのスライダー操作を取り消せる場合があったのを修正。MAtricks ウィンドウのスライダー操作の取り消しは、Undo General 設定に依存するようになりました。
専用のレイアウト・オブジェクトに設定された Layout ウィンドウをインポートすると、Layout ウィンドウが選択されたレイアウトにリセットされてしまうのを修正。選択されたレイアウト・オブジェクトの設定が正しくインポートされます。
カラーテーマを初めてエクスポートするときに失敗していたのを修正。
ドライブ選択ボタンをスワイプしてリストからUSBドライブを選ぶと、正しいドライブが選択されず、エクスポートに失敗するのを修正。
フィーチャが定義されていないアトリビュートを持つキューをコピーすると、ソフトウェアがクラッシュする場合があったのを修正。
MAtricks オブジェクトを保存して名前を指定すると、その名前が MAtricks オブジェクトに適用されていたのを修正。Store MAtricks "Cool Setup" は、"Cool Setup" という名前の MAtricks オブジェクトを作成します。
値を名前ではなく数値で指定すると、存在しない値をプロパティに設定できていたのを修正。例えば Set Selection 1 MAtricks "InvertStyle" 100 としても、このプロパティには100種類も値がないため、適用されません。
インポート先を指定しないで複数オブジェクトを一度にインポートする際、少なくとも一つが空でない場合に処理方法を尋ねられなかったのを修正。インポート先が空でない場合は、常に処理方法を尋ねるポップアップが出ます。
個別タイミングを持つシーケンスをエクスポートしてインポートすると、タイミングが 0 になってしまうのを修正。
特定ページのエクゼキュータをオフにするコマンド "Off Page x" が機能しなかったのを修正。
複数のレイアウト要素を作成し、Layout Editor で Object セルを編集すると、レイアウト内で同じフィクスチャを何回も割り当てることが可能だったのを修正。フィクスチャやサブフィクスチャは、一つのレイアウト内で1回しか割り当てられません。
シーケンスのインポートで、Individual Fade と Delay タイムが無視されていたのを修正。
複数オブジェクトに連番名を付ける場合、番号の前にあるゼロ部分が2番目以降のオブジェクトで失われてしまうのを修正(例: Label Group 1 thru 10 "Hoge 00001")
アピアランスやスクリブルが割り当てられた MAtricks オブジェクトをセレクションに呼び出すと、アピアランスやスクリブルも呼び出され、その後、新しい MAtricks オブジェクトを保存すると、そのアピアランスやスクリブルも含まれてしまうのを修正。MAtricks オブジェクトを呼び出しても、割り当てられているオブジェクトは呼び出されません。
レイアウト1を移動または削除すると、すぐに新しいレイアウトが作成されていたのを修正。どのレイアウトも削除できるようになりました。レイアウト1がない状態も可能です。
オブジェクトが割り当てられていないエクゼキュータの Assign メニューを閉じると、空のエクゼキュータ・オブジェクトが保持されていたのを修正。空のエクゼキュータは削除されるようになりました。
ソフトウェア実行時に追加されたライブラリ・ファイルが、List Library で表示されなかったのを修正。
ロックされてたオブジェクトにインポートすると、そのオブジェクトが変更されてしまうのを修正。
データプールを既存のものにインポートすると、ソフトウェアがクラッシュする場合があったのを修正。
タイムコード・ショーをインポートすると、Timeline 表示モードで、最初のトラックのイベントが表示されないことがあったのを修正。すべてのイベントが正しくインポートされます。
既存グループへのマージを行うと、Move Grid Curser 設定がオフになってしまうのを修正。
グループを Command Line History に一覧表示したとき、Move Grid Cursor 設定が表示されなかったのを修正。
プール・オブジェクトを9999を超えるIDに移動すると失われてしまうのを修正。このような移動は行われなくなりました。複数のオブジェクトを移動した場合は、ID9999以下へのオブジェクトだけが移動されます。
タイムコード・トラックのターゲットを変更しても、トラック内のイベントが以前のターゲットを参照したままだったのを修正。
タイムコード・ショーで使われているシーケンスのキューを削除した場合、タイムコード・ショーの再生時に空になったイベントが Go+ として処理されていたのを修正。空のタイムコード・イベントは、次のキューをトリガーしません。
シーケンスをコピーする際に、キューパート番号が失われていたのを修正。
データプールをエクスポートし、それを再度インポートすると、すべてのプリセットが失われてしまうのを修正。
"Copy Cue 1" を実行すると、ソフトウェアがクラッシュする場合があったのを修正。キューをクリップボードにコピーしても、クラッシュしなくなりました。
Update メニューを開いているときに Blind を押すと、選択されているシーケンスの現在のキューが更新されていたのを修正。
レイアウト内で Fixture At Fixture が機能しなかったのを修正。フィクスチャを選択し、コマンドラインに At を追加してから、Layout ウィンドウでフィクスチャを選択すると、Fixture At Fixture 機能が実行されます。
既存ビューへの Store 操作を取り消すと、後で元のビューボタンを呼び出そうとしたときに、ビューボタンが空にあることがあったのを修正。
タイムコード・イベントの記録で、トリガータイムが 0s のイベントがすべて記録されるとは限らなかったのを修正。
MAtricks ウィンドウで Shuffle をタップしたとき、適切な値が生成されなかったのを修正。
"At Decimal16 512" のように、Decimal16 または Hex16 で値を指定してコマンドを入力すると、正しく動作しなかったのを修正。
AddToCmdline が Yes に、Execute が No に設定されていて、Move などの機能キーワードを含むマクロが、最初のオブジェクトをタップするとすぐにコマンドが実行されてしまうのを修正。ソースやデスティネーション・オブジェクトをタップして指定する必要があるマクロが適切に動作します。
All および All For Selected で、要求されるアトリビュートが保存されなかったのを修正。
既存プリセットに保存する際に、このプリセットに対する異なるフィクスチャの値がプログラマで非アクティブになっていると、新しいフィクスチャのためのプリセット・リンクがプログラマで保持されなかったのを修正。プログラマで非アクティブ化されたプリセット・リンクは、プリセット保存時に、他のフィクスチャがプログラマでプリセット・リンクを取得することを妨げません。
例えば Move Group 1 Thru 3 At Group 3 のようにソースとデスティネーションの一部が重なっていると、オブジェクト・リストの移動が失敗するのを修正。
ギャップを持つオブジェクト範囲を移動すると、デスティネーションでギャップが取り除かれてしまうのを修正。グループ1と3があり、Move Group 1 Thru 3 At Group 11 でそれらを移動すると、グループ11と13になります。
ロックされたタイムコード・ショーに新しいイベントを記録しようとすると、ソフトウェアがクラッシュする不具合を修正。
プリセット内の統合データすべて上書きしても、プリセット上に Integrate シンボルが表示されたままだったのを修正。
既存のキュー範囲に保存を行うと、不要なキューが新たに作成されてしまうのを修正。
Output Configuration でXLRポートの編集中に、grandMA3 卓の数字キーで値を入力した場合、Please を押しても認識されず、Edit XLR ポップアップが閉じなかったのを修正。
アトリビュート・エンコーダを押し回して離すと、Align がリセットされてしまうのを修正。別のアトリビュート・エンコーダを使い始めたとき、最初にリセットされます。
grandMA3 onPC for Windows のzipファイルが、macOS の Archive Utility で正しく展開できなかったのを修正。
アピアランスの背景色を黒に変更すると、追加使用されいる画像のサイズが変わってしまうのを修正。
Update メニューの Cue Only および Sequence Mode 設定が、Save Preferences をタップしても保存されなかったのを修正。
Keep Activation を有効にして、プリセットの保存直後にキューを保存すると、プリセットへのリンクがキューに保存されなかったのを修正。
MAtricks オブジェクトのインポートで、Speed 値が正しく取り込まれなかったのを修正。
別のキューパートにすでに保存されているアトリビュートをパート0に保存するとき、Allow Duplicate 設定が考慮されなかったのを修正。
タイム範囲の先頭に置かれたタイムコード・イベントが、正しく再生されない場合があったのを修正。
Layout ウィンドウを Setup モードに切り替えた場合、エクゼキュータに割り当てられたオブジェクトに含まれるフィクスチャを SelFix キーで選択しても、それらがレイアウト内で選択されなかったのを修正。
フェイザー・レイヤの値が Default 値に設定されていると、プリセットに保存されなかったのを修正。

接続

説明
macOS 上で動作する grandMA3 onPC ステーションがセッション内に2台以上ある場合、Network メニューの同じ行に両ステーションが交互に表示されることがあったのを修正。これらはステーションは個別に表示されます。
ステーションをセッションに招待するとき、両方のステーションが同じ Session Slot を使用することがあったのを修正。セッションの初期化やステーションの招待時に、各ステーションは一意的なスロットIDを取得します。
Webリモート内に表示されている Layout ウィンドウがちらつく場合があったのを修正。
卓をスタンドアロン・モードで起動したとき、DMXをローカルに出力できなかったのを修正。
Webリモート接続がまだ確立されていない段階で、その接続を利用しようとすると、ソフトウェアがクラッシュする場合があったのを修正。
長いOSCコマンドの後に短いコマンドを受信すると、長いコマンドの断片が System Monitor に表示されることがあったのを修正。
シーケンスを開始するマクロが割り当てられたキーをOSCでトリガーすると、卓のGUIがフリーズすることがあったのを修正。
セッションで接続された卓からトリガーされた場合、OSCコマンドが送信されなかったのを修正。
OSCに対する入力と出力の切り替えボタンが正しく機能していなかったのを修正。
OSC Configuration メニューで SendSendCmd が有効になっていないと、OSCコマンドを送信できなかったのを修正。SendCmd だけが有効な場合にも、OSCコマンドが送信されます。
タイムコード信号がI/Oノードに入力され、その接続が失われたとき、タイムコード・スロットの After Roll が開始されなかったのを修正。I/Oノードがセッションから消えると、After Roll が開始されます。
sACN パケットのDMX入力がスタートコードを無視していたため、代替 sACN パケットを DMX sACN パケットとして処理していたのを修正。sACN の DMX入力 は、DMX sACN パケットだけを処理します。
SFTP経由で卓に接続すると、インストールされている他バージョンのユーザデータにアクセスできなかったのを修正。
インターフェースのIPアドレスを変更しようとしたときに、入力欄が空のままだとソフトウェアがクラッシュする不具合を修正。この場合、以前のIPが残ります。
セッションに参加しているステーションのIPアドレスを変更すると、予期せぬセッション動作が生じることがあったのを修正。IPアドレスをまったく異なるサブネットに変更しても、そのステーションが常にセッションに参加しようとするわけではありません。
アプリケーション起動後、初めて onPC command wing または onPC fader wing を接続すると、onPC ステーションの優先度が Normal にリセットされてしまうのを修正。
メインのタイムコード・ソースからバックアップのタイムコード・ソースへの引き継ぎがスムーズに行われなかったのを修正。最初に受信していたタイムコードがなくなった場合、途切れることなく別ステーションの入力に引き継がれます。

パッチ

説明
Patch でコピー&ペーストを行うと、UUID の重複が生じていたのを修正。
フィクスチャタイプの編集時に Mode Master の Oops で割り当てを取り消すとクラッシュする場合があったのを修正。
Patch でフィクスチャタイプが割り当てられていないフィクスチャを選択しようとすると、ソフトウェアがクラッシュする場合があったのを修正。
ネストされたジオメトリ参照を持つフィクスチャタイプのDMXフットプリントが、正しく算出されていなかったのを修正。
Fixture ID に既存のIDを設定しようとしたときに、確認のポップアップが表示されなかったのを修正。
フィクスチャの Mode を編集する際、ショーファイルで利用可能なすべてのモードが表示されていたのを修正。選択したフィクスチャで利用可能なモードだけが表示されます。
複数のフィクスチャに対して同じ Label コマンドを再適用すると、同名のフィクスチャができてしまっていたのを修正。
Universal フィクスチャを削除または移動できていたのを修正。Universal フィクスチャの削除、移動、またはカット&ペーストはできなくなりました。
"Global" をIDタイプとして割り当てることができていたのを修正。"Global" フィクスチャタイプと Glabal ステージは非表示になり、編集も割り当てもできなくなりました。
Patch でフィクスチャのカット&ペーストを行うと、レイヤとクラスの情報が失われていたのを修正。
Patch でフィクスチャの "Master React" を "None" または "Group" に設定しても機能しなかったのを修正。設定は、Patch から抜けたときに保存されます。
GDTF をインポートしたとき、チャンネル機能の "RealAcceleration" プロパティが正しく取り込まれていなかったのを修正。
GDTF をインポートしたとき、チャンネル機能がカスタム名ではなくデフォルト名で取り込まれていたのを修正。
新しいレイヤやクラスを既存のものに追加してから Patch に入り直すと、フィクスチャのレイヤやクラス割り当ても変わってしまうのを修正。
DMXアドレスを持たないフィクスチャをレイアウトに追加するとクラッシュする不具合を修正。
膨大な数のフィクスチャを追加すると、ソフトウェアがクラッシュする場合があったのを修正。

フェイザー

説明
フェイザーを編集して、Speed を大幅に変更すると、ソフトウェアがクラッシュする場合があったのを修正。
フェイザーのフォームを Phaser Editor で変更すると、位相が0°にリセットされていたのを修正。フォームを変更しても、個々の位相値は保持されます。
複数のステップをまとめて選択してから、今まで操作していなかったアトリビュートのエンコーダを回すと、選択したステップに対して異なるアトリビュート値が設定されるのを修正。

プレイバック

説明
通常の値を Cue Only オプションで空のキューに保存すると、キューにフェイザー・マーカが表示されることがあったのを修正。マーカは、キューに複数のステップがある場合にのみ表示されます。
シーケンス・エンコーダバーの I< を押したとき、最初のキューではなく CueZero にジャンプしていたのを修正。
OffCue にタイミングが設定されているシーケンスをオフにしたとき、シーケンスのマスター位置が100%未満になっていると、その位置に比例した最後のタイム範囲でのみ Fade と Delay が動作していたのを修正。
プリセットを用いるアトリビュートをアクティブにするとき、シーケンスのマスター・フェーダ位置が考慮されていなかったのを修正。マスターでスケーリングされたシーケンスで再生されるプリセットを用いるアトリビュートをノックインすると、マスター・フェーダにしたがった値がアクティブになります。
Phase が設定されたレシピを再生すると、その Phase ではなくレシピ内で指定されたプリセットの Phase が使用されていたのを修正。
Restart Mode が Current Cue の場合、OffCue 内のフェードタイムでシーケンスがオフになっていると、現在のキューで再開されなかったのを修正。
Pause を押すことで Follow キューを休止できなかったのを修正。

ウィンドウ

説明
タイムコード・マーカとタイム範囲が、そのポップアップにおいて、開始タイムではなくIDによってソートされていたのを修正。
Backup メニューで異なるタブに切り替えたとき、ファイルの選択状態が保持されなかったのを修正。
画面1とは別の画面で Layout ウィンドウを Setup モードにすると、Encoder Bar ウィンドウからのエラーが System Monitor に出力されるのを修正。
MAtricks ウィンドウで Layers の MAtricks プロパティに対し最初に - をタップすると、このプロパティにアクティブな値がなかった場合、不適切な値が設定されてしまうのを修正。このような場合はデフォルト値が設定されます(例: Speed プロパティでは60BPM)。
Recipe Editor で、MAtricks のスペルが間違っている箇所があったのを修正。
Timecode Editor で Setup モードに移ったとき、タイトルバーをタップし直さないとタイムコード・エンコーダバーに切り替わらなかったのを修正。
Fixture Sheet で、選択されたCIDに対する表示ルールが、FIDのルールと一致していなかったのを修正。
2Port Nodes の Port Configuration メニューで、ポート1に対する有効なデータが表示されなかったのを修正。
巨大な画像を含む Layout ウィンドウを表示すると、UIのパフォーマンスが大幅に低下するのを修正。
タイムコード・ショーを編集するとき、Timecode Editor が直ちに表示されない場合があったのを修正。
プール・ウィンドウの上にオーバーレイがある場合、背後のプール・ウィンドウをスクロールすると、選択されたプール・オブジェクトのフォーカス枠がオーバーレイ上に透けて表示されていたのを修正。
現在のワールドでは除外されているフィクスチャがグループに含まれている場合、そのグループが Layout ウィンドウに表示されない不具合を修正。
Date & Time メニューで日時などの数値プロパティを編集する場合、電卓のタイトルバーに間違った値範囲が表示されていたのを修正。
HSB混色システムの Hue と Saturation 用のDMXチャンネルを持つフィクスチャで Color Picker を用いると、クラッシュする不具合を修正。
タイムコード・スロットの Generator Start Time を変更しても、表示タイムがすぐに更新されなかったのを修正。
タイムコード・スロットの配色のうち、Generator と External source が正しく表示されなかったのを修正。これらの配色は、Timecode Slot プール、およびタイムコード用の Clock ウィンドウで用いられます。
異なるサブフィクスチャの同一チャネル機能が、エンコーダのチャネル機能セレクタやエンコーダの電卓にマージされない場合があったのを修正。
フィクスチャのディマー値を変更したとき、それとは別のフィクスチャのディマー値が Layout ウィンドウに間違って表示されることがあったのを修正。
ツールバーの Copy/Cut/Paste ボタンの順序が統一されていないウィンドウがあったのを修正。
画面キーボードをロシア語に変更した場合、yY の文字表示が間違っていたのを修正。
電卓の位置を移動すると、追加の入力ボタン(例: Channel Sets など)が機能しなくなるのを修正。
フェーダ/エンコーダを持たないエクゼキュータにシーケンスやグループを割り当てたり、フェーダ/エンコーダの機能を後から Empty に変更したりした場合、プレイバックバーのマスター・フェーダに "MST" が表示されたままになっていたのを修正。
オブジェクトが割り当てられていない特殊エクゼキュータのラベルに内部名が表示され、それが空ではでないように見えていたのを修正。空の特殊エクゼキュータには名前が表示されません。
Speed Readout が Seconds に設定されている場合、エクゼキュータ・ラベルに正しい値が表示されなかったのを修正。
新しいショーファイルで、エンコーダバーから Phaser Editor を開閉すると、エンコーダバーに黒いレイヤボタンができてしまうのを修正。
アピアランスだけが割り当てられている Smart View オブジェクト、アピアランス、プリセットでは、プール・オブジェクトのラベルに影が表示されなかったのを修正。
Fixture Sheet の CID セルに、サブフィクスチャのIDとして常にフィクスチャIDが表示されていたのを修正。フィクスチャがサブフィクスチャとCIDを持つ場合、サブフィクスチャに対してCIDが表示されます。
IPアドレス用電卓の 0. ボタンが、卓のキー配置と比べて入れ替わっていたのを修正。/ 以外は卓のキー配置と同じです。
小さな画面(ディスプレイ6、7)に Layout ウィンドウを表示したとき、すべてのレイアウト要素を表示しきれない場合があったのを修正。
In & Out メニューに移ったとき、前回選択していたタブが復元されなかったのを修正。
内部ウィングの WingID を変更しても、エクゼキュータの内容が更新されなかったのを修正。
Timecode Show Settings の Frame Readout ボタンに、正しい設定値が表示されなかったのを修正。
新たに保存されたキューが、プレイバックバー内のエクゼキュータ・ラベルに表示されなかったのを修正。現在キューの次がその新しいキューになるとすぐに、それがエクゼキュータ・ラベルに表示されます。
利用可能な DMX Readouts の順序が、それを選択できるすべての場所で統一されていなかったのを修正。
ショートカットが有効な場合、Xkeys ウィンドウのボタンに対応するショートカットが表示されなかったのを修正。
MVRファイルをインポートした後に 3D ウィンドウを開くと、ソフトウェアがクラッシュする場合があったのを修正。
画面6、7に表示される Clock Window Settings が大きすぎたのを修正。画面に合わせて適切に縮小されます。
画面6、7で新バージョンをインストールすると、EULA ポップアップで I agree や I DO NOT agree をタップできなかったのを修正。
Layout ウィンドウで、サブフィクスチャのIDが正しく表示されない場合があったのを修正。

付記


既知の制限

onPC ステーションに対してネットワーク経由でソフトウェアを更新する場合、インストール先システムでインストール処理中に確認が必要です。
キューから参照されているプリセットを削除した場合、削除を取り消しても参照は復元されません。
ネットワーク上に複数の GlobalMaster があり、それぞれが同じセッション/ロケーション名を持っている場合、優先度の高いステーションがユーザ入力なしに引き継ぎます。すべてのステーションの優先度が同じ場合、Online Time が最も長いステーションが、すべてのステーションに対する GlobalMaster になります。
旧バージョンのショーファイルを読み込むと、プログラマ内容が破棄されます。
ビデオソースとしてのNDIは、フィーチャ・プレビューです。